MySQL Router not yet bootstrapped when install openstack using openstack-charms

Hello,

Currently I’m installing openstack using openstack-charms deployment tools base on this url Open Source Cloud Computing Platform Software - OpenStack. then I run the following command to deploying vault : juju deploy --to lxd:3 vault juju deploy mysql-router vault-mysql-router juju add-relation vault-mysql-router:db-router mysql-innodb-cluster:db-router juju add-relation vault-mysql-router:shared-db vault:shared-db

the result is “MySQL Router not yet bootstrapped” likes on the picture bellow :slight_smile:

when I login into lxd, then i checked unit-vault-mysql-router-2.log file I get message error : ERROR unit.vault-mysql-router/2.juju-log server.go:327 Failed to bootstrap mysqlrouter: Error: Bootstrapping of Router with multiple metadata_cache sections not supported

can anyone help me to troubleshoot this error ?

Thanks, Herdiansah

It sounds like you’re hitting Bug #1971565 “charm no longer works with latest mysql-router ver...” : Bugs : MySQL Router Charm - maybe try with the most recent package version (which has a patch)?

hello,

I reconfigure & deploy new juju controller, i try follow again this url https://docs.openstack.org/project-deploy-guide/charm-deployment-guide/latest/install-openstack.html I run command : juju deploy --to lxd:3 vault juju deploy mysql-router vault-mysql-router juju add-relation vault-mysql-router:db-router mysql-innodb-cluster:db-router juju add-relation vault-mysql-router:shared-db vault:shared-db

the result is : vault/1* —> Vault service not running
vault-mysql-router/2* —> Failed to connect to MySQL

I login into 172.17.1.27 & I get error log “ERROR unit.vault-mysql-router/2.juju-log server.go:327 Failed to connect to database due to ‘(2003, “Can’t connect to MySQL server on ‘127.0.0.1:3306’ (111)”)’”

can you help me, how to fix this problem ?

Thanks

I have the same error also. All MySQL related services failed not only vault. help please… Thanks

try to see this link https://bugs.launchpad.net/charm-mysql-router/+bug/1971565

This problem was caused by a MySQL upstream change.

Either use/upgrade charm mysql-router to channel 8.0.19/stable or upgrade the mysql package to [1] on the nodes hosting the mysql-router instances.

[1] https://launchpad.net/ubuntu/+source/mysql-8.0/8.0.29-0ubuntu0.20.04.3

Dear mr pmatulis,

Thanks for your information. now I successfully installed openstack-charm after using mysql-router channel 8.0.19.

Thanks