Vsphere bootstrap creates 2 nics with same mac

I’m facing problems bootstrapping a vsphere controller at the moment.
(See: https://jaas.ai/docs/vsphere-cloud )

The controller machine (and subsequent deploys) creates machines with 2 nic:s with the same MAC addresses and hence the same IP-address:es. This obviously causes networking issues and I’m not sure what part juju has in this atm.

Subsequent “juju deploy foobar” equally creates machines with this very same problem (even reusing the MAC-address from the juju controller host).

I’m trying to figure out if the problem is in vsphere or in juju. Since this worked fine on a previous controller (unfortunately torn down so I don’t know the version).

I bootstrap with the following:

juju bootstrap vmware01 iuba-vmware --config config.yaml --bootstrap-constraints=“mem=32G cores=8” --model-default model-default.yaml

The content of config.yaml:

primary-network: VLAN_802
datastore: H280-VIC847-0001
allow-model-access: true

The content of the model-default.yaml:

datastore: H280-VIC847-0001
primary-network: VLAN_802
apt-mirror: https://af.scania.com/artifactory/ubuntu

The resulting controller machine ends up with 2 nic:s as the picture belowScreenshot%20from%202019-09-12%2016-08-15

The MAC-addresses are the same on those NIC:s and hence also given the same IP-addresses.

This never happened before. The version of juju is: 2.6.8-bionic-amd64

snap list
juju 2.6.8 8873 stable canonical✓ classic

Anyone that has a clue on whats going wrong here?

Things I’ve tried with no avail:

  • Messing around with external-network and primary-network with no avail.
  • Messing around with templates.

Is this the same issue brought up in Bug #1800940 “Juju bootstrap vmware vsphere not working with vsa...” : Bugs : juju ?

VMWare doesn’t support Spaces and thus multi-nic support. It might be confusing if the template that’s started with includes multiple nics since Juju isn’t prepared to handle it.

1 Like

@rick_h Its not the same bug, but I’m reading from the conversation that Daniel Bidwell gets the same kind of problem. I’m linking the comment here: Comment #24 : Bug #1800940 : Bugs : juju

The template ( created automatically by the bootstrap ) doesn’t seem to have two nics. I’ll double check tomorrow.

Additional hints to what might be happening here:

After removing the redundant/extra nic and attempting a “juju deploy ubuntu” - the created machine also gets 2 nics with the same MAC as the controller node + all the same cpus, ram, etc. as the controller/bootstrapped node.

I’m also experiencing that I even get 4 nics on the controller node from a bootstrap (!!!) when I’m adding in bootstrap parameters “external-network” + “primary-network”.

I added to the bug-report here: Comment #26 : Bug #1800940 : Bugs : juju

I reverted to version 2.6.6 of the juju snap.

“sudo snap revert --revision=8594 juju”

Then I performed the exact same bootstrap command as I did with 2.6.8. The resulting controller now gets properly a single nic and subsequent deploys also renders into working machines.

The workaround seems to be reverting to 2.6.6.

Hi Erik, sorry for the slow response on this - we’ve all been travelling to a team meetup. But several of us are looking at this now to understand what’s happening here. I’ve created a bug from this post to track progress: Bug #1844125 “vsphere creates machines with multiple clashing ni...” : Bugs : juju


Thanx for the attention. It seems from the discussion in Bug #1844125 that the revert to 2.6.6 still affects Daniel Bidwell, so perhaps this is something else.

The detail I mentioned above, that, when providing “external-network” + “primary-network” the controller gets 4 (four) nics. Maybe that would help you track down where this happens.