Volumes not attached in non-default models


when I am deploying Charmed Kubernetes on OpenStack in default model, I do have automatically attached volumes to the server instance, because I specified constraint


in controller bootstrap process.

But when I create different model using

juju add-model <model_name>

and deploy kubernetes there, the server instances doesn’t have volumes attached, which cause failures because of low disk space.

I can’t see any differences between models, where is specified that that volumes should be created or not in model? Or how it works?

Thanks in advance!


I think you can set the default values using:

juju set-model-constraints root-disk-volume=volume

Or you can do that on a deploy

juju deploy foo --constraint root-disk-source=volume


I fixed it with

juju add-model <model-name> --config root-disk-source=volume

Many thanks, thought! I will make note as another possibility.


Just as my note, I realized that command:

juju add-model <model-name> --config root-disk-source=volume

is not enough. I have to also set constraint for the model:

juju set-model-constraints -m <model-name> root-disk-source=volume

Now it works!

1 Like