Vault service not running and Failed to connect to MySQL

I had this issue while deploying openstack xena on ubuntu 20.04 .I notice juju has update from juju 2.9.28 to juju 2.9.29 i belive that is what caused the problem so i ssh into the vault container to check here is my output : Error checking seal status: Get https://127.0.0.1:8200/v1/sys/seal-status: dial tcp 127.0.0.1:8200: connect: connection refused

I got the same error too. in my case its not vault only, every services which has its own mysql-router gets the same error. help please…

ict@maas-controller:~$ juju status Model Controller Cloud/Region Version SLA Timestamp openstack-cloud maas-controller mymaas/default 2.9.29 unsupported 15:32:55Z

App Version Status Scale Charm Channel Rev Exposed Message ceph-osd 16.2.7 blocked 4 ceph-osd stable 513 no Missing relation: monitor mysql-innodb-cluster 8.0.29 active 3 mysql-innodb-cluster stable 15 no Unit is ready: Mode: R/O, Cluster is ONLINE and can tolerate up to ONE failure. nova-compute 23.1.0 blocked 3 nova-compute stable 550 no Missing relations: messaging, image vault blocked 1 vault stable 54 no Vault service not running vault-mysql-router 8.0.29 blocked 1 mysql-router stable 15 no Failed to connect to MySQL

Unit Workload Agent Machine Public address Ports Message ceph-osd/0* blocked idle 0 10.10.10.70 Missing relation: monitor ceph-osd/1 blocked idle 1 10.10.10.76 Missing relation: monitor ceph-osd/3 blocked idle 3 10.10.10.78 Missing relation: monitor ceph-osd/4 blocked idle 4 10.10.10.79 Missing relation: monitor mysql-innodb-cluster/0 active idle 0/lxd/0 10.10.10.80 Unit is ready: Mode: R/O, Cluster is ONLINE and can tolerate up to ONE failure. mysql-innodb-cluster/1 active idle 1/lxd/0 10.10.10.82 Unit is ready: Mode: R/O, Cluster is ONLINE and can tolerate up to ONE failure. mysql-innodb-cluster/2* active idle 3/lxd/0 10.10.10.81 Unit is ready: Mode: R/W, Cluster is ONLINE and can tolerate up to ONE failure. nova-compute/0* blocked idle 1 10.10.10.76 Missing relations: messaging, image nova-compute/1 blocked idle 3 10.10.10.78 Missing relations: image, messaging nova-compute/2 blocked idle 4 10.10.10.79 Missing relations: image, messaging vault/2* blocked idle 4/lxd/0 10.10.10.84 8200/tcp Vault service not running vault-mysql-router/0* blocked idle 10.10.10.84 Failed to connect to MySQL

I Just belive it update issues from juju 2.9.28 to 2.9.29

I have this same error also. Tried to rebuild as first time all MySQL related services failed. This time stopped at Vault as this has failed again for the same reason.

I have the same error also. All mysql related services failed not only vault.

just try to see this link

I fix the problem go to the lxd container you install mysql-router then open the conf file in /var/lib/mysql/vault-mysql-router/mysqlrouter.conf

  1. i change unknown_config_option = error to unknown_config_option = warning
  2. [metadata_cache:bootstrap] to [metadata_cache:jujuCluster]
  3. [routing:bootstrap_rw] to [routing:jujuCluster_rw]
  4. [routing:bootstrap_ro] to [routing:jujuCluster_ro]
  5. [routing:bootstrap_x_rw] to [routing:jujuCluster_x_rw]
  6. [routing:bootsrap_x_ro] to [routing:jujuCluster_x_ro]
  7. remove the last [metadata_cache:jujuCluster]

Because the default cluster name is jujuCluster not bootstrap then restart the service for every mysql-router then it works

This problem was caused by a MySQL upstream change.

Either use/upgrade charm mysql-router to channel 8.0.19/stable or upgrade the mysql package to [1] on the nodes hosting the mysql-router instances.

[1] https://launchpad.net/ubuntu/+source/mysql-8.0/8.0.29-0ubuntu0.20.04.3

8.0.19/stable is not working error says MySQL router not yet bootstraped