Terminology tweak: Operator Framework -> ops

Users of the Python Operator Framework / ops library: just to let you know, per the updated Juju Terminology doc (currently Canonical-private, so not linked here), we’re standardizing and simplifying some of the terms we use to describe parts of the Juju ecosystem.

Specifically, we’ll now be referring to the Operator Framework as “the ops library” or, where applicable, simply “ops”. I’ve updated the README and API reference to this effect.

This is for a few reasons: to simplify the term, for consistency with the Python package name (which is already ops), and to avoid a naming clash with Red Hat’s “Operator Framework”.


Love that you work on getting a good consistency in the terminology! This will help when trying to communicate about Juju generally.


Hi Erik!

Yes that’s the plan. We’ve been iterating over the past weeks on some simplified terms that will hopefully reduce some of the confusion for people getting started. More on that soon!

Cheers, Jon

1 Like