Sunbeam Cannot join openstack cluster

Hello, this time I tried multi node installation, and I cannot join a node to bootstraped cluster. I’m doing everything according to

My error message is:

ostack@ostack-2:~$ sunbeam cluster join --role control --role compute --role storage    --token  MYTOKENHERE
WARNING: Minimum system requirements (4 core CPU, 16 GB RAM) not met.
An unexpected error has occurred. Please run 'sunbeam inspect' to generate an inspection report.
Error: End Of File (EOF). Exception style platform.
<pexpect.pty_spawn.spawn object at 0x7fd7bb0c8d30>
command: /snap/openstack/288/juju/bin/juju
args: ['/snap/openstack/288/juju/bin/juju', 'login', '--user', 'ostack-2']
buffer (last 100 chars): b''
before (last 100 chars): b'\x1b[91mERROR\x1b[0m no current controller\r\n'
after: <class 'pexpect.exceptions.EOF'>
match: None
match_index: None
exitstatus: None
flag_eof: True
pid: 1209
child_fd: 6
closed: False
timeout: 30
delimiter: <class 'pexpect.exceptions.EOF'>
logfile: None
logfile_read: None
logfile_send: None
maxread: 2000
ignorecase: False
searchwindowsize: None
delaybeforesend: 0.05
delayafterclose: 0.1
delayafterterminate: 0.1
searcher: searcher_re:
    0: re.compile(b'^please enter password')

On my first node:

ostack@ostack-1:~$ juju users
Controller: sunbeam-controller

Name                     Display name  Access     Date created  Last connection
admin                    admin         superuser  2 hours ago   2 hours ago
ostack-1*                              superuser  2 hours ago   just now                superuser  1 hour ago    never connected

The weirdest part is, few days ago i did everything the same and managed to add one node no prob, and had this problem with the very next one

I tried again today on snap version 301, same error

User from first node has SSH keys exchanged with the node i’m trying to add.