sunbeam bootstrap fails (nova error)

I tried to bootstrap:




in various configurations, all fail to bootstrap with:

nova/0* error idle hook failed: “cell-database-relation-changed”

where the ‘hook failed’ might change.

Looks like I’m not the only one with that problem. A more detailed problem description can be found here:

Is there anyone who was able to do a sunbeam bootsrap during the last two weeks?

I’d be surprised if that’s totally broken. I tried to bootstrap on a fresh installed minimal ubuntu 22.04 server on a physical machine. Maybe I have just some unresolved dependencies.


I have successfully installed 2023.1 and 2023.2/edge using multinode setup instructions on a physcial machine with 4xcore, 2x1G nic, 32GB RAM, 2x SSD( 250GB for system/snaps and 500GB for Microceph)

Openstack come up and are usable but are very unstable as mysql-0 and multiple mysql-routers restart every now and then. Seem to be caused py Pebble failing to reach mysql-0 primary address for some reason which trigger a restart (or if it actually redeploy the pod, not sure).

Hi Magnus,

thanks for your reply. How did you configure you network?

I’ve got it managed to bootstrap one time yesterday, with the same configuration that failed about 50 times before. Unfortunately this did not survive a reboot. It was unusable then. The next bootstrap failed the same way all the other ones failed. I have 20 CPU cores on my machine, so maybe there is a race in the bootstrap.


I have two 1Gbps nics. First Nic uses dhcp with reserved ip. Second nic is left unconfigured as bootstrap process change its configuration during deployment. This nic need to be on same network as you use to hand out floating ip.

I was confused about what IP and subnet to give as response two the first two questions during bootstrap. Ended up using same /24 as I get from dhcp and for metallb I use a range from same Subnet that is excluded from dhcp server.

Am not in front of my computer atm but can send the complete config later for your reference.


Would be nice if you could send your complete config. I also wonder why two physical NICs are needed. Wouldn’t two virtual NICs that are connected on L2 to one physical NIC do the same?

Another thing, does IPv6 work for external networking? I have several public IPv6 /64 subnets, but just a few public IPv4 addresses, so I’d like to use IPv6 whenever possible.

Btw. my initial problem seems to be a bug. See the link I’ve added above.