Request: rename library charms.istio_pilot.v0.istio_gateway_name to charms.istio_pilot.v0.istio_gateway_info

Hello! Can we please rename library charms.istio_pilot.v0.istio_gateway_name to charms.istio_pilot.v0.istio_gateway_info? Thanks!


Renaming libs is not a trivial operation - they were not designed for that, and I wonder what’ll happen if you later want to revive gateway_name or split the functionality of gateway_info into more libraries again - which will be confusing to current and future users.

What happens if you just create a new istio_gateway_info library? Or maybe move everything out and leave istio_gateway_name as a mostly-deprecated stub with some message to that effect?

Another option is for you to upload the istio_gateway_info library and then I can delete istio_gateway_name - deletion is somewhat less risky.

If not, please let me know and I can do the rename for you, just be aware of the above :slight_smile:

  • Daniel

Sorry for the late reply, we have decided to delete istio_gateway_name and create istio_gateway_info

Not a problem - let me know if you want me to hold until you’ve uploaded istio_gateway_info, or whether I’m clear to delete istio_gateway_name now.

  • Daniel

@roadmr could you please delete istio_gateway_name now? We are safe to do that now. (:

it’s gone :slight_smile:

  • Daniel
1 Like