Request: Rename charm lib: kafka_libs


Could I rename charms.kafka.v0.kafka_libs to charms.kafka.v0.kafka_snap?

Renaming libs is not a trivial operation - they were not designed for that, and I wonder what’ll happen if you later want to revive kafka_libs - which will be confusing to current and future users.

Can you maybe move the snap-related functions to a new kafka_snap thing and leave the non-snap ones there? Or maybe move everything out and leave kafka_libs as a mostly-deprecated stub with some message to that effect?

If not, please let me know and I can do the rename for you, just be aware of the above :slight_smile:

  • Daniel

Currently there are no users as it’s in development, the library will still be in use but with a more generic name. I think I accidently named it not knowing it wasn’t a simple fix!

If deleting the lib is easier, that’s fine too and I can republish with a new name while the charm is coming into shape, what do you think?

Actually, upon review I think your suggestion of stubbing kafka_libs and adding charms.kafka.v0.kafka_snap is a better idea, happy to close this!

1 Like

Great, let me know if you ever need me to look at really deleting it and we can; but if you can do with the stubbing strategy, that’s easier for all involved.

  • Daniel