Problem with publishing nova metrics using ceilometer agent

I’ve migrated my openstack lab from kolla-ansible and have deployed 3 ceilometer and one gnocchi units using juju. And this is my ceilometer pipeline.yaml file:

  - name: meter_source
     - "*"
      - meter_sink
  - name: meter_sink
     - gnocchi://
export pipeline=$(cat ./pipeline.yaml)
juju config ceilometer pipeline-yaml=$pipeline
juju config ceilometer enable-all-pollsters=true
juju config ceilometer-agent enable-all-pollsters=true
juju run-action ceilometer/leader ceilometer-upgrade

everything seems ok but there’s no my pipeline configurations inside ceilometer machines when accessing to /etc/ceilometer inside them (using juju ssh command). And the publisher endpoint won’t receive any data. Is there anything which I’ve forgot to do?

Having the same problem currently. Did you ever figure this out @cybercoder?

Yes, I’ve installed new stack using current latest stable “Yoga” with this tutorial and the ceilometer deployed well and pipeline.yaml has been affected.

Just be sure to deploy ceilometer from the yoga/stable channel.

1 Like