Openstack - charm deployment issue

newbie question:
After running the charm-based deployment of OpenStack using MaaS and juju, I am not able to deploy qcow2 instances.

The error message after launching the instance is:
unsupported configuration: Emulator ‘/usr/bin/qemu-system-x86_64’ does not support virt type ‘kvm’

… so, I guess there went something wrong with the neutron charm during the deployment of my environment.

It is interesting to note:
checking the compute type with “juju nova-compute virt-type” is showing kvm, but with the GUI it is showing QEMU.

can anybody point me to a possible solution. What do I have to fix in order to be able to start qcow2 instances?

Hi Juergen.

I suggest attempting to create a VM with the command line client. That will tell us whether the problem is with the dashboard or not. The documentation you followed shows how to do that but let us know if you need assistance.

I guess you are using ESXi or something for your MAAS machines rather than real tin?

Hi Peter - Yeap, i checked that already, the CLI is telling me it is kvm.

Yes - that’s correct I am using ESXi.

What I meant was, can you create a VM with openstack server create?

No - I am getting the same error if I am launching an instance via cli

@jmorgenstern by default ESXi guests do not have the right CPU features for virtualisation. You need to add the following config to the .vmx file for each of the machines you define there.

vhv.enable = "TRUE" 

You can’t set this from the vsphere client, you will need to SSH to the hypervisor and make the setting.

You will need to shut off the VM before you make the edit.

Hope that helps!

arghhh - I totally ignored the nested design here ;-(
You are spot on @routergod - the ESX config was the key !!!


1 Like