Microstack - Invalid image identifier or unable to access requested image. (HTTP 400)

I can create volumes and virtual machines if i leave the create new volume box unticked, then i create a volume and map it manually and it works fine. But if i try and create a volume from an image it errors out giving me - Invalid image identifier or unable to access requested image. (HTTP 400). I have tried various images types (qcow2, raw, iso) with no success.

Hi! Looks like you’re running into the same behavior I did a few days ago:

tl;dr: you need to set up MicroStack with Cinder Loop Device support. If you haven’t done this when you created the snap, the best advice would be to uninstall and then reinstall the Microstack Snap:

sudo snap install microstack --devmode --beta

Then initialize it with:

sudo microstack init --auto --control --setup-loop-based-cinder-lvm-backend --loop-device-file-size 50

where device-file-size 50 will give you 50 GB of usable cinder space.

Additionally you will need to run:

sudo tee /var/snap/microstack/common/etc/cinder/cinder.conf.d/glance.conf <<EOF
glance_ca_certificates_file = /var/snap/microstack/common/etc/ssl/certs/cacert.pem

And finally:

sudo snap restart microstack.cinder-{uwsgi,scheduler,volume}

@jimkoen Thanks for sharing what you found :slight_smile: It helped me get past the same error that was reported by OP.

I am a little curious, how did you figure this out?

Thank you so much for this. It fixed my issue!

1 Like