Microstack and remote access to Hoziron dashboard

Hi, I installed microstask. How do I set up remote access to horizon ? Locally, opens, from a remote machine it writes 502 Bad Gateway after authentication. Routing to the network is registered, the host is available. The variant without iptables.

Hi Sergey,

Have you set up port forwarding as described here? OpenStack for the edge, micro clouds and developers (see “Accessing Horizon on a remote server”). It seems like you may have, but I’m not fully sure.

If you continue to see the issue, it would be interesting to see if there are any clues in the horizon/nginx error logs.


My question is firstly how to make remote access without ssh port forwarding. But I do it and got the same result. Now I look again to my problem and I see that only https://x.x.x.x/project/ url is getting “502 Bad Gateway” error. The over parts of dashboard is working.

nginx error log: 2022/05/18 09:51:40 [error] 6750#0: *31416 upstream prematurely closed connection while reading response header from upstream, client: y.y.y.y, server: , request: “GET /project/ HTTP/1.1”, upstream: “uwsgi://unix:///var/snap/microstack/common/run/horizon.sock:”, host: “x.x.x.x”, referrer: “https://x.x.x.x/project/network_topology/

Hi Corey, I tried to install Microstack on a remote server and I’m able to access Horizon with the default IPs ( However, when I try to configure the IPs before init as below:

sudo snap install microstack --devmode --channel beta sudo snap set microstack config.network.ext-cidr=10.x.y.0/24 sudo snap set microstack config.network.ext-gateway=10.x.y.1 sudo microstack.init --auto --control

I get “504 Gateway Time-out”, nginx/1.19.0, on login… Any suggestions? Thanks!