Microk8s installation issues

I keep running into the same issue trying to get microk8s running. The machine was completely wiped and is running Ubuntu 20.04… I also now have it directly connected to my University network so I am not proxying through other machines (i.e. my MAAS host).

All I’ve done so far is:

sudo snap install microk8s --classic --channel=1.21/stable

I also did microk8s enable dns storage

Regardless of what I do, I am getting a CrashLookpBackOff error on the calico-kube-controllers-* service. I’m a bit stuck as at this point, as I haven’t really done anything “off script” yet… it’s a stock installation (although I did install nvidia-headless-510 for GPU drivers). I had this same error before even without installing drivers though, nor do I see that is the likely source of my problems.

The only slightly atypical thing on this machine is I have it also connected to a local network adapter, but I made sure my primary (and only) gateway is pointing to my University’s network…

Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface default _gateway UG 0 0 0 eno3 UH 0 0 0 cali36e2b440148 UH 0 0 0 calic22759821c2 UH 0 0 0 cali53835659c52 UNVNETWORK U 0 0 0 eno3 U 0 0 0 enp68s0f1 U 0 0 0 eno1

I was also having this issue. As a workaround for myself I just did microk8s disable ha-cluster.

Ok— that’s good to know. At least it’s not just me…

Were you also running 1.21?

I’m using 1.23

Surprised that issues is popping up… I am trying to get kubeflow installed which isn’t apparently compatible yet with > 1.21…

It seems like the coredns service is up and running… but it says READY 0/1… Does that make sense? Also I tried to enable dashboard and am running into the same issue… I can’t tell if there are some weird firewall issues, but I disabled ufw at this point.


So on a stock Ubuntu 20.04 system, does anyone know of a microk8’s snap version/channel that isn’t having the ha-cluster issues?

So just for reference, I was able to get past some of the hiccups, although I find it a bit baffling why this worked…

— Machine Specs — Ubuntu 20.04 Stocks, 192GB of RAM, 1TB SSD

Network 1: This adapter has the primary gateway, – is actually my MAAS head node…

Network 2: University IP address – Public

Of note, both networks have a gateway, but MAAS sets Network 1 as the default gateway.

— Network 1 as gateway didn’t work by default… proxy issues which I guessed would cause an issue.

Second scenario: After installation, edited my netplan config, and made Network 2 (and my univesity subnet…) the default gateway. Oddly… this didn’t work (and I tried several times). However wget , curl, etc. work without any issues, so I do have network connectivity.

Current attempt: Network 1 is set as default gateway (i.e. hops to my MAAS server)

BUT… before installation of microk8s, I made sure I updated my /etc/environment and set up http* proxies and no_proxy.

I am still having some issues getting kubeflow set up, but at least the default microk8’s installation now seems to be working.

Wanted to bump this… trying again.

I am pretty sure a lot of my aggravation is proxy related, but I am not clear how to debug intelligently…

sudo snap install microk8s --classic --channel=1.21/stable
microk8s kubectl get all -A

So even at this early stage (I already added myself to microk8s group), the calico-controller consistently throws a crashloop error…

So , I then

microk8s config > ~/.kube/config
microk8s enable rbac dashboard dns storage metallb:
microk8s kubectl get all -A

While that machine should have direct internet access, as a hail mary I modified my /etc/environment and set up the proxy config. The proxy address points to a MAAS headnode that I used to provision the machine initially…


1 Like

So I also decided to inspect my microk8s cluster, and got an exciting debug message…

1 Like