Juju Team Updates - Week #22 2021

Hi everyone, below you can find the updates from the Canonical Juju Team for the week starting on the 31st of May 2021.

Have a great weekend!

:juju: JUJU

  • CI optimisations: Use ephemeral nodes to burst workloads.
  • CI: Fix manual integration tests
  • Standardise HTTP Client use within Juju. The proposed changes standardises the strategy of request retries and HTTP Keep Alives in one central location. [JU016] (GCE, Simplestreams & Goose)

This is what I worked on:

  • Spec for server-side expansion and transactional deployment of bundles.
  • Investigation of LP 1928796: “Unable to deploy bundle with sidecar and pod_spec charms”
  • Landed fix for LP 1884794: " juju show-cloud vsphere --include-config does not produce config output", it’ll be released in 2.9.5
1 Like
  • Most time spent investigating and working towards a solution for long quiescence time after upgrade to 2.9.
  • Looked into an issue with Bionic machines failing to provision on GCE.
  • Removed stand-alone uniter manifolds - we no longer run these as separate agents on VMs.
1 Like
  • Finalised fix for handling SIGTERM on Juju container agent for Kubernetes
  • Ongoing: Reviewing LXD documentation
  • Ongoing: Developing spec for Pebble around Autostart
1 Like
1 Like

Both of the above two are waiting for more feedback and will get iterated further if need.

1 Like
  • 2.9.4 candidate release
  • report service addresses for sidecar charms
  • fix upgrade model agent lookup for k8s controllers
  • fix display of scale and workload version in juju status
  • dynamically update apt mirrors on all nodes; works on k8s too
  • use mongo storage for external auth macaroon keys
1 Like
  • Worked on resources fetching for CharmHub in the Juju Python Library
  • Fixed a model operator upgrade bug when moving from 2.8* -> 2.9*
  • Worked on a credentials bug in the migration of 2.8* -> 2.9*. This is todo with 2.8 models on a 2.9 controllers understanding the new Kubernetes credentials
  • Found and investigated an upgrade bug for 2.9 where our provider credentials are not being established when running correctly in the same cluster.
1 Like