Juju controller vsphere

Hi everyone, my name is Nicola and I am new about Juju. I am working on an on premises lab into my vsphere infrastracture but i got immediately in stuck and i dind’t get the way to get out. i have created the cloud in the both ways: using the interctive wizard than with YAML file and everything seems fine, but when i try to create the controller i got the following error:

18:26:14 INFO  juju.cmd.juju.commands bootstrap.go:920 combined bootstrap constraints:
18:26:14 INFO  cmd bootstrap.go:398 Loading image metadata
Looking for packaged Juju agent version 2.9.27 for amd64
18:26:14 INFO  juju.environs.bootstrap tools.go:82 looking for bootstrap agent binaries: version=2.9.27
18:26:14 INFO  juju.environs.bootstrap tools.go:84 found 1 packaged agent binaries
Located Juju agent version 2.9.27-ubuntu-amd64 at https://streams.canonical.com/juju/tools/agent/2.9.27/juju-2.9.27-ubuntu-amd64.tgz
18:26:14 INFO  cmd bootstrap.go:579 Starting new instance for initial controller
**18:26:15 ERROR juju.cmd.juju.commands bootstrap.go:883 failed to bootstrap model: datacenter 'xxxxx' not found**
18:26:15 INFO  juju.provider.common destroy.go:21 destroying model "controller"
18:26:15 INFO  juju.provider.common destroy.go:32 destroying instances
18:26:15 ERROR juju.cmd.juju.commands bootstrap.go:1637 error cleaning up: destroying instances: datacenter 'xxxx' not found
18:26:15 INFO  cmd supercommand.go:544 command finished

i tried to install govc to check if my dataceter has folder before datacenter label but also there everything seems ok. can someone help me or suggest me a good tutorial?

thanks in advance Nicola

1 Like

Could you send the bootstrap command you used and the name if the datacenter?

hi i tried a lot of different command …i started with juju bootstrap vsp-dtech vsp-dtech-controller where vsp-dtech is my sphere cloud and i finisched with

juju bootstrap vsp-cloud vsp-cloud-creds * ** --credential vsp-cloud-creds * ** --config primary-network=“INSIDE” ** ** --config datastore=“NMB-VOL11” --show-log**

but every time i got the same error. The name of the datacenter is Ditech. here the output of govc ls



i appreciate Nicola

Hey Nicola, great to have you here :slight_smile:

Could this issue be related?

Also, there’s some documentation on bootstrapping a controller to vSphere, if that helps

I will also ping some folks in the Juju team to see if they can add to it.


1 Like

hi all, thanks a lot for help me, i was able to fix the issue and go ahead with the controller setup. I did a stupid error in vcenter user configuration so juju bootstrap can login in virtual center but it can see anything because i dindn’t propagete privileges to child objects.



@tmihoc - how does the documentation for setting up vsphere and bootstrap examples look like today? Perhaps its missing stuff that matters when setting up persmissions in vshpere etc. and “gotchas” like this above?

I haven’t looked at it in a while, but this looks like a good time to revisit—thanks for bringing it to my attention!

1 Like