Juju controller enable-ha in manual-cloud without MAAS

Hi charmhub folks!

I with my team are curious about deploying juju without MAAS, so we did it at last 2 months ago and it was running well until several days ago. We found that api controller with only 1 machine suddenly flapping, the service of controller in systemd was running, but from logs, it was dead then up again to serve requests. So, when we try to use juju commands (ex: juju status, juju machines, etc) it was taking long times, and also the status of our applications and machines were flapping in down/up state, but it accessible

So, we try to add more controllers to make it Highly Available using juju enable-ha command. But we stuck because juju said error that it require space, then we try to config the controller to use space that we manually created from juju space create, and using juju controller-config juju-ha-space=‘name-of-space’ for configuring ha-space

ERROR invalid config "juju-ha-space"="controller-mongospace": machines with no addresses in this space: 0

Any suggestion for enabling HA in juju without using MAAS ?

Juju version: 2.9.42

Output of juju status -m controller

Model       Controller  Cloud/Region    Version  SLA          Timestamp
controller  maasnt1     maasnt/default  2.9.42   unsupported  03:59:56Z

Machine  State  Address      Inst id             Series  AZ  Message
0        down  manual:             bionic      Manually provisioned machine
1        down  manual:  bionic      
2        down  manual:  bionic 

2 month ago only machine 0. Yesterday we add 2 more machine manually using juju add-machine ssh:ubuntu@

But after running juju enable-ha --to 1,2 the error shown that no juju-ha-space configured.

ERROR juju-ha-space is not set and a unique usable address was not found for machines: 0
run "juju controller-config juju-ha-space=<name>" to set a space for Mongo peer communication

But when we try to use juju status -m openstack , all of our applications still there with status down then flapping up then down again