Juju connects or attempts to connect through the wrong address

real Maas—real juju–Production system testing -----no vm or lxd or snap

juju connects or attempts to connect through the wrong address

maas server is on xxx.xxx.15.205 but juju tries to connect to xxx.xxx.0.117

bootstrapping begins at xxx.xxx.15.205:5240/MAAS. everything works great and then, the process times out because of where juju tries to connect.

I maybe wrong, but it looks like MAAS is not routing traffic from xxx.xxx.15.205 to xxx.xxx.0.117 and placing the client on the xxx.xxx.0.1, the MAAS dhcp side does not work" it does not communicate with MAAS at the xxx.xxx.15.205"

Creating Juju controller “maas-controller” on maas-cloud/default
Looking for packaged Juju agent version 2.8.4 for amd64
Launching controller instance(s) on maas-cloud/default…

  • xaf4rg (arch=amd64 mem=4G cores=2)
    Installing Juju agent on bootstrap instance
    Fetching Juju Dashboard 0.2.0
    Waiting for address
    Attempting to connect to

any suggestions.

it sounds like the following is happening:

  1. Your Juju client reaches out to the MAAS server and asks it to create a Juju Controller.
  2. MAAS provisions a machine to serve as a controller. The address of that machine is xxx.xxx.0.117
  3. Your Juju Client cannot route to that machine, and thus fails to further bootstrap it.

To fix this, you need to make sure that MAAS is provisioning a machine that the client can reach. To do so, you might need to move the Juju client to a different place – e.g., setup a jump box in a routable place within MAAS.

Or you might want to exercise more control over which MAAS machine gets setup as a Juju controller. For example, you could tag a MAAS Pod that has routable networking with “juju-controller”, then pass that tag into the Juju bootstrap command.


I have been a user of maas/juju on heavy metal since version 12.0.4 lts., and I have never come across an issue like this, in the days of 12.0.4 lts, the client had to be on the lan side where the heavy metal was… in this case xxx.xxx.0.1., NAT was setup on the maas server “region” and the client had full internet access, so when calling the maas server or bootstrapping juju–juju would hit the maas at xxx.xxx.15.205 and then hit the juju gui at xxx.xxx.0.5:22.

this has all changed. in this version it appears that the clients have no internet access though the maas server. even though it is working good, with commissioning of heavy metal.

I have tried to NAT, But it is not working at all, it keeps changing back the network settings.

anyway I figure this is something that could be worked on by you guys. future maas setup should have some form of NAT built in, the client like in previous versions must have internet access when siting on the heavy metal side. that will allow juju client to hit maas and hit the metal when juju init.

I hope that we can figure this out. I am actually upgrading again.

P.S how do you setup some of those suggestions you gave earlier.

thank again.