juju certficade problem to connect micrk8s cluster


I have microk8s cluster running and I just installed juju for manager my cluster… When I run juju clouds the return contains one error about certificate:

g0004830@p-br-pr-cta-gt2-mk8s-01:~/.local/share/juju$ juju clouds
Only clouds with registered credentials are shown.
There are more clouds, use --all to see them.
You can bootstrap a new controller using one of these clouds...

Clouds available on the client:
Cloud      Regions  Default    Type  Credentials  Source    Description
localhost  1        localhost  lxd   0            built-in  LXD Container Hypervisor
microk8s   0                   k8s   1            built-in  A local Kubernetes context
ERROR could not get clouds from controller "microk8s-localhost": starting proxy for api connection: connecting k8s proxy: Get "": tls: failed to verify certificate: x509: certificate signed by unknown authority (possibly because of "crypto/rsa: verification error" while trying to verify candidate authority certificate "")

I tried update my certificates with this commands:

g0004830@p-br-pr-cta-gt2-mk8s-01:~/.local/share/juju$ sudo microk8s.refresh-certs -c
[sudo] password for g0004830: 
The CA certificate will expire in 3638 days.
The server certificate will expire in 353 days.
The front proxy client certificate will expire in 353 days.

g0004830@p-br-pr-cta-gt2-mk8s-01:~/.local/share/juju$ sudo update-ca-certificates
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...

Version of microk8s / snap / juju

g0004830@p-br-pr-cta-gt2-mk8s-01:~/.local/share/juju$ microk8s.version 
MicroK8s v1.28.3 revision 6089

g0004830@p-br-pr-cta-gt2-mk8s-01:~/.local/share/juju$ snap version
snap    2.61.1
snapd   2.61.1
series  16
ubuntu  22.04
kernel  5.15.0-91-generic

g0004830@p-br-pr-cta-gt2-mk8s-01:~/.local/share/juju$ juju --version

How to fix this problem?