Grafana charm broken. Let's fix it!

Anybody that has tried to install the Grafana charm recently has likely gotten the error, “hook failed: install”. If not I want to hear!

Well if you have, it is likely there is a known cause and a possible solution.

An astute Github user posted that Grafana had a repo change recently:

The official news was broken by Grafana here:

That said, it looks like the deb repo needs updated and maybe the GPG key.

I’m curious if there is CI testing this and hopefully there is now a job broken saying to update this… If not… there should be?

Are there any links to the SCM where ‘prometheus-charmers’ keeps the source for the charms? Is there CI for it? Does it have tests?


1 Like

The grafana charm source can be found here:

I’ve not tested it recently but see that there’s recent updates to it. Maybe it’s not been released in a bit. Might be worth filing an issue/etc there.

@db0west, the grafana charm was indeed updated, but the conjure-up spell lagged behind. That has since been fixed in the latest charmed-kubernetes spell:

And released in the latest conjure-up snap:

stable: 2.6.8-20190930.1409 2019-09-30 (1056) 102MB classic

We do have CI for the grafana charm, but unfortunately not for the conjure-up spells :frowning: It’s worth noting that the recommended way to add Prometheus/Grafana to k8s is with a bundle overlay versus a conjure-up spell. See the k8s monitoring docs for more details:


Thanks for pushing this update through Kevin.

@db0west how did you install conjure-up? If you’ve installed it as a snap, the fix should be with you now.

It was a snap. I’ll try updating it soon and running it with monitoring.

It worked! So I guess I’m part of ‘CI’ :wink:

snap refresh


Charmed K8s >
[x] Prometheus/Grafana