Error when deploy mongodb charm

A few weeks ago I deployed charm offline mongodb-k8s by cloning charm by charm folder dowloaded, mongodb started ok with OSM services on Ubuntu18.04 VM. After VM reboot some times, mongodb-k8s application is stuck with status waiting, pod mongodb-k8s-0 status Init:0/1. I have also tried remove-application then deploay again but I still get the error.
And i have a bit confuse why container k8s_juju-operator_mongodb-k8s-operator not clean after I remove-application mongodb-k8s. I attached some logs below.

$ juju status
Model  Controller  Cloud/Region  Version  SLA          Timestamp
osm    osm         k8scloud      2.8.8    unsupported  02:50:14Z

App          Version       Status   Scale  Charm        Store  Rev  OS          Address         Notes
mongodb-k8s  mongo:latest  waiting      1  mongodb-k8s  local    6  kubernetes  

Unit            Workload  Agent  Address      Ports      Message
mongodb-k8s/5*  waiting   idle  27017/TCP  waiting for container

$ docker logs --tail 20 -f k8s_juju-pod-init_mongodb-k8s-0_osm_99959ace-d9b4-44d4-b21b-6a6fcdd40940_0
2021-03-05 01:49:26 INFO juju.cmd supercommand.go:54 running jujud [2.8.8 0 1d2677ae1d65f10bd15e9e29ab5e0f0cca70898a gc go1.14.10]
2021-03-05 01:49:26 DEBUG juju.cmd supercommand.go:55   args: []string{"/var/lib/juju/tools/jujud", "caas-unit-init", "--debug", "--wait"}

$ docker logs --tail 20 -f k8s_juju-operator_mongodb-k8s-operator-0_osm....
2021-03-05 02:51:04 INFO juju.worker.caasoperator.uniter.mongodb-k8s/5 uniter.go:302 unit "mongodb-k8s/5" started
2021-03-05 02:51:04 INFO juju.worker.caasoperator.uniter.mongodb-k8s/5 uniter.go:314 hooks are retried true
2021-03-05 02:51:15 ERROR juju.worker.caasoperator caasoperator.go:641 could not get pod "unit-mongodb-k8s-5" "mongodb-k8s-0" Get "": net/http: TLS handshake timeout
2021-03-05 02:51:15 INFO juju.worker.caasoperator.uniter.mongodb-k8s/5 uniter.go:286 unit "mongodb-k8s/5" shutting down: catacomb 0xc0009bc400 is dying
2021-03-05 02:51:15 INFO juju.worker.caasoperator.runner runner.go:558 stopped "mongodb-k8s/5", err: getting pod status for unit "unit-mongodb-k8s-5", container "mongodb-k8s-0": Get "": net/http: TLS handshake timeout
2021-03-05 02:51:15 ERROR juju.worker.caasoperator.runner runner.go:442 exited "mongodb-k8s/5": getting pod status for unit "unit-mongodb-k8s-5", container "mongodb-k8s-0": Get "": net/http: TLS handshake timeout