Error on juju deploy kubeflow-lite

Hi, guys.

I need to some help, please.

When I run the command: sudo microk8s juju deploy kubeflow-lite --trust

I receive this error: ERROR resolving with preferred channel: Post “”: dial tcp: lookup on server misbehaving

Below it is the debug:

SO: Ubuntu 16.04.7 LTS

Kubernetes: Microk8s 1.21/stable


I am getting a Error as well. Not the same Error but I am getting no route to host. But i am able to ping and curl the

you may need to update codedns configmap. Please run the command below and see if nameserver ip address are properly set.

microk8s.kubectl get configmap -n kube-system coredns -o yaml > coredns.yaml

If not, update coredns.yaml and run the command below

microk8s.kubectl apply -f coredns.yaml

1 Like

Hi @halilagin, I’m having a similar error message.

I runned your command and the coredns.yaml is as follows:

apiVersion: v1
  Corefile: |
    .:53 {
        health {
          lameduck 5s
        log . {
          class error
        kubernetes cluster.local {
          pods insecure
        prometheus :9153
        forward .
        cache 30
kind: ConfigMap
  annotations: |
      {"apiVersion":"v1","data":{"Corefile":".:53 {\n    errors\n    health {\n      lameduck 5s\n    }\n    ready\n    log . {\n      class error\n    }\n    kubernetes cluster.local {\n      pods insecure\n      fallthrough\n    }\n    prometheus :9153\n    forward .\n    cache 30\n    loop\n    reload\n    loadbalance\n}\n"},"kind":"ConfigMap","metadata":{"annotations":{},"labels":{"":"EnsureExists","k8s-app":"kube-dns"},"name":"coredns","namespace":"kube-system"}}
  creationTimestamp: "2023-03-04T13:59:39Z"
  labels: EnsureExists
    k8s-app: kube-dns
  name: coredns
  namespace: kube-system
  resourceVersion: "45724"
  uid: d487bae2-3c85-48e2-841d-8696ee0df090

How would I change this to solve the problem as you suggest?

Thank you for your collaboration!