ERROR "cannot resolve charm URL" when deploying Anbox Cloud

I am trying to deploy Anbo Cloud via juju. My command is juju deploy cs:~anbox-charmers/anbox-cloud-core --overlay ua.yaml

But when I run it I get the following output:

Opening an authorization web page in your browser.
If it does not open, please open this URL:
ERROR cannot resolve charm URL "cs:~anbox-charmers/anbox-cloud-core": cannot get "/~anbox-charmers/anbox-cloud-core/meta/any?include=id&include=supported-series&include=published": access denied for user "myusername"

What should I do?

I am having the same issue. The charm does not seem to exist anymore on the charm store. I also tried charmers/anbox-cloud which opens up a web page for ubuntu SSO. I succesfully sign in, but I get a permission denied statement on the terminal.

Hey All,

Anbox Cloud is a commercial product and the charms are not freely available. In order to make use of Anbox Cloud you need to have a commercial relationship with Canonical and have a subscription of Ubuntu Advantage.

Technically the charms exists but your Ubuntu account needs to be whitelisted for access.

If you’re interested in Anbox Cloud, please reach out via Anbox Cloud - Scalable Android in the cloud


I’ve purchased Ubuntu advantages, trying to install still denied me, is there any ways i can get whitelisted?

I’ve tried contacting anbox-cloud, but i didn’t get any replies