`conjure-up` deploy of charmed kubernetes is not settling (cloud is MAAS)

Hi, I have tried to conjure-up charmed kubernetes and kubernetes core many times in the past days. Very recently it worked for me with AlwaysAllow auth on the master. Every time recently I am using RBAC for the master.

I have not had a successful deploy after many tries and consistently see these problems:

Hanging on:

  • Waiting for CNI plugins to become available
  • etcd -> Errored with 0 known peers
  • waiting for 3 kube-system pods to start

Any help would be appreciated. I keep freeing up by KVM host and retrying with slightly different settings (like flat layout for storage or LVM) but nothing has worked. Since I had recent deploys that worked flawlessly I am looking for a way to fix this problem.

I have even tried restarting the juju controller VM, but to no avail.

Please help.

Hi @db0west,

Sorry for your woes, but I can assure you that Charmed Kubernetes works well on MAAS - I deploy it a lot on my home MAAS.

First, I’d recommend not using conjure-up. It’s no longer recommended in the official install docs for Charmed Kubernetes, and I suspect that in your case it’s installing out-of-date charms which are causing at least part of your problems.

Instead, I’d recommend using the Juju client directly to add your MAAS cloud, bootstrap it, and then juju deploy charmed-kubernetes, which will get you the latest and greatest charms with k8s 1.18.

If you want/need to modify the bundle first, you can download it here, and then deploy your local edited copy with juju deploy ./bundle.yaml.

Hope this helps, but if you get stuck please keep asking - we’ll help you through it.


So true! I had that thought as well as soon as I posted. And the results of juju deploy cs:bundle/canonical-kubernetes-933 showed me that conjure-up don’t work as well.

Deploy successful. Shame I was a fan of that cool curses++ interface. Oh well. Seems to be a theme, the GUIs are cool and nice looking, but the cli is really what works and does everything.

@tvansteenburgh well. It did work. At first… But only with the default settings deployed. Turns out I need to modify the bundle and set the following for kubernetes-master

  channel: 1.18/stable                                                                                     
  allow-privileged: "true"                                                                                 
  authorization-mode: "RBAC" 

Unfortunately, the charm does not seem to settle with allow-privileged and RBAC.


In case RBAC precludes allow-privileged: "true" I am trying with just authorization-mode: "RBAC" tonight.

The reason I am adding this change is to get ceph and rook working with my cluster. With my setup, the regularly documented and recommended juju charms for ceph storage just don’t work. I had a working setup with older versions of charmed-k8s and I am trying to get it working again with 1.18.

I need a default storage-class that dynamically provisions and I am pretty sure I am on the right track with trying to enable RBAC per the rook.io instructions.

It’s hard to say without more info about what problems you’re seeing, but one thing you might try is setting authorization-mode="RBAC,Node" instead - that’s our recommended configuration as documented here.