Charmed Openstack deployment

Hi everyone, I’m trying to deploy a charmed version of Openstack. I have deployed MAAS, registered the nodes and have my juju controller up and running. Up to this point, everything seems to be working perfectly fine, however, if I setup the repository cloud for the source, the update and package installation fails.

> 2022-04-19 15:19:38 WARNING unit.ceph-osd/0.install logger.go:60 E: Failed to fetch  403  Forbidden [IP: 8000]
> 2022-04-19 15:19:38 WARNING unit.ceph-osd/0.install logger.go:60 E: The repository ' focal-updates/yoga InRelease' is not signed.
> 2022-04-19 15:19:38 INFO unit.ceph-osd/0.juju-log server.go:327 Couldn't acquire DPKG lock. Will retry in 10 seconds

I have tried importing the key from the machine but it doesn’t work. I don’t know what else to try to fix it, if I remove the origin setting for the Openstack version, the packages install correctly but that way I don’t know the version of Openstack that is being deployed.

The charms that support OpenStack Yoga are not yet officially released.

What are the exact commands you used to update the package archives?

I have tried other versions as well, I have tried wallaby and Victoria.

series: focal
  openstack-origin: &openstack-origin cloud:focal-yoga
  data-port: &data-port br-ex:bond0

this is what I used for my yaml file.

I removed my previous reply when I saw that you had tried with Wallaby and Victoria. These should work. Can you pastebin the bundle you are using?

Sure, I’m using the following yaml file.

Yaml File

and I run with with juju deploy ./script.yaml

So focal-yoga won’t work when you are requesting charms via the cs: prefix. What this does is give you the current 21.10 charms release, which does not support OpenStack Yoga.

You said Wallaby doesn’t work. Perform a simple test:

juju add-model wallaby
juju deploy --series focal --config source=cloud:focal-wallaby cs:ceph-osd