Cannot create service URLs ,caused by: invalid region "RegionOne"

Hi team,

I’m getting the error:cannot create service URLs ,caused by: invalid region “RegionOne”, when i run the command juju bootstrap test…where test is my openstack cloud name

mogfrey@aio1:~/Downloads$ openstack region list


| Region | Parent Region | Description |


| RegionOne | None | |


juju outputs: juju --version 2.9.42-ubuntu-amd64

These are the outputs from openstack: openstack --version openstack 5.5.0

Kindly advise what could be the issue

What value is in the OS_REGION_NAME environment variable when you run openstack commands?

How did you add the openstack cloud to juju?

Hi Heather,

Thanks for your response.

My value for OS_REGION_NAME is RegionOne. I created the openstack cloud interactively using Juju add-cloud --client then responding to the prompts. Even tried bootstrapping by explicitly providing the region name but didn’t work. Tried to create the yaml file and create the cloud using it…Still got the same error.

It took me so long to try and figure out the cause.Eventually I decided to downgrade the version of Juju to 2.8 and it worked. So Must be some bug in the version I was using and something in my environment that triggered a bug…

I think you should file a Juju bug on this.