Calico/Canal issue

Could anyone help me understand how to deploy Calico with k8s 1.23 Juju bundle? Is there any example? As I tried several ways deployment it’s still pending on “Configuring Calico” and there are messages from juju debug-log and directly on nodes calicoctl could not create calico node.

I also tried to use “juju deploy canonical-kubernetes-canal” and it was deployed successfully but I’m unable to understand if I can use k8s network policy or Calico network policy. I tried both but does not seems that it’s working out-of-the-box. I also tried to deploy Calico manifest - the current one and also old one for version Calico 3.10.1 (why is there still such old version from year 2019?) but it failed to create DaemonSet for canal due to error “Forbidden: disallowed by cluster policy” and old one was even worse. I did not changed anything after deploy regarding RBAC or cluster policy.

My aim is to have functional k8s cluster (ideally 1.23) deployed with Juju with Calico CNI and to be able to use k8s/calico Network Policy.