504 gateway timeout on charmcraft?

seeing the following when attempting to upload after authenticating

craft-store error: Issue encountered while processing your request: [504] Gateway Time-out.                                            
Full execution log: '/home/username/snap/charmcraft/common/cache/charmcraft/log/charmcraft-20220323-180122.329069.log'

should I restart ?

I tried again and got a

Upload failed with status 'rejected':                                                                                                  
- review-error: Cannot insert package. An upload with that digest (SHA3-384: '3a460e19ef811a62ae1a92eea6f9bffaccb75443b5f0008dc000365bfcfc2168f3463c391d422c76b4aff6b144a713d4') already exists in the database.         


Seems it worked and the upload went through… I see a revision and bumped it to beta channel… testing it now.

1 Like

Hi @emcp, we had a problem earlier this morning with Charmhub but I thought that was fixed. I will check what’s going on. Just to be sure, you can run charmcraft login and that doesn’t return an error, and also, you can Log In and see your charms clicking “Log In” at charmhub.io?

EDIT: I see you edit :slight_smile:

1 Like

just wanted to confirm that yes, all is looking well… glad it was only a minute there :slight_smile: thanks for the quick confirmation @pedroleaoc